It seems your ruby installation is missing psych

スポンサーリンク

もうすべてを諦めて、さくらのレンサバにRuby環境を作ることにした。
Ruby最新版をいれるところまではうまくいったが、gemがうまく動いてない模様。

It seems your ruby installation is missing psych

libyamlが無くて起こられているらしいので、色々調べてみて以下のコマンド実行。

少しややこしいのは、libyaml-devをインストールするだけではダメで、etc/psychでruby extconf.rbを実行する必要がある。

# aptitude install libyaml-dev
# cd ~/ruby
# cd ext/psych
# ruby extconf.rb
# cd ~/ruby
# ./configure --prefix=$HOME/.rbenv/versions/1.9.3-p327
# make
# make install

cannot load such file –zlib とか It seems your ruby installation is missing psych (for YAML output). を解決

うーん、うまくいかないorz

スポンサーリンク