AdMobをcocoaPods経由で導入しようとしたら「Apple Mach-O Linker Error」

Podfileに書いたのはこんな感じ。

platform :ios
pod 'Google-AdMob-Ads-SDK'


こちらに書いてあることそのままで直りました。
Xcode 4.6 で プロジェクトに AdMob を導入時にハマった。その1 – iPhoneに魅入られて。


最初はPodfileにおけるiosのバージョンを6.0って書いておきながら、6.1のシュミレーターを使ってるからか?とおもったけど、全然関係なかった。。

cocoaPodsを使ってれば依存関係大丈夫だろうし、うーんうーん言っていたら、普通に必要なフレームワークが足りなかったという罠。

XcodeのPodsではない方に、StoreKit.framework をいれたら解決。
逆にPodsの方に入れても動かなかった理由はわからず・・・

スポンサーリンク
スポンサーリンク