symfony propel:build-modelができない

symfony propel:build-model

をしたら以下のエラーがでました。

PHP Fatal error: Declaration of SequentialTask::addTask() must be compatible with that of TaskContainer::addTask() in /usr/share/pear/symfony/plugins/sfPropelPlugin/lib/vendor/phing/tasks/system/SequentialTask.php on line 35


うんうん悩んだ挙句、
結局先輩に質問することに(涙)

どうやらphingがsymfonyにすでに入っていて、
pearからインストールしてしまったものと衝突していることが原因とのこと。


そのためrootで

pear uninstall phing

でpearからアンインストール。

できました。。。。。


ちなみに以下のページも参考にしました。

スポンサーリンク
スポンサーリンク